[USRP-users] Timed Commands for GPIO (X3x0 and N2x0)

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[USRP-users] Timed Commands for GPIO (X3x0 and N2x0)

Martin Braun via USRP-users
Is it possible to set the GPIO pins on the N or X series radios at specific times the same way that front end params (freq, gain, etc) can be set?

Thanks!

_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
Reply | Threaded
Open this post in threaded view
|

Re: [USRP-users] Timed Commands for GPIO (X3x0 and N2x0)

Martin Braun via USRP-users
Hi Dave,

Yes.  Just use the same set/clear_command_time() calls around your calls to set the GPIO values.

Regards,
Michael

On Thu, Sep 29, 2016 at 9:39 AM, Dave NotTelling via USRP-users <[hidden email]> wrote:
Is it possible to set the GPIO pins on the N or X series radios at specific times the same way that front end params (freq, gain, etc) can be set?

Thanks!

_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com



_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
Reply | Threaded
Open this post in threaded view
|

Re: [USRP-users] Timed Commands for GPIO (X3x0 and N2x0)

Martin Braun via USRP-users
Michael,

    Thank you!!

-Dave

On Thu, Sep 29, 2016 at 12:43 PM, Michael West <[hidden email]> wrote:
Hi Dave,

Yes.  Just use the same set/clear_command_time() calls around your calls to set the GPIO values.

Regards,
Michael

On Thu, Sep 29, 2016 at 9:39 AM, Dave NotTelling via USRP-users <[hidden email]> wrote:
Is it possible to set the GPIO pins on the N or X series radios at specific times the same way that front end params (freq, gain, etc) can be set?

Thanks!

_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com




_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
Reply | Threaded
Open this post in threaded view
|

[USRP-users] Error Using X310 ( NI USRP 2940 R)

Martin Braun via USRP-users
Hi All,

I’m quite new of this field. I started to use USRP because I’m working with a 5G network simulator/emulator.

I have a NI USRP 2940 R in which  I installed the Ettus X310 firmware. When I run the code I get this error: 

UHD Warning:
    Unable to set the thread priority. Performance may be negatively affected.
    Please see the general application notes in the manual for instructions.
    EnvironmentError: OSError: error in pthread_setschedparam
Checking for USRPs : UHD 003.010.000.000-release (3.10.0)
Found USRP X300
-- X300 initialization sequence...
-- Determining maximum frame size... 1472 bytes.
-- Setup basic communication...
-- Loading values from EEPROM...
-- Setup RF frontend clocking...
-- Radio 1x clock:184.32
terminate called after throwing an instance of 'uhd::assertion_error'
  what():  AssertionError: block_def
  in void uhd::usrp::device3_impl::enumerate_rfnoc_blocks(size_t, size_t, size_t, const uhd::sid_t&, uhd::device_addr_t, uhd::endianness_t)
  at /build/uhd-SfT4TV/uhd-3.10.0.0/host/lib/usrp/device3/device3_impl.cpp:148

Aborted (core dumped)

Any ideas?

Thanks a lot in advance!!

Best Regards.

Francesco.
 

_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com
Reply | Threaded
Open this post in threaded view
|

Re: [USRP-users] Error Using X310 ( NI USRP 2940 R)

Martin Braun via USRP-users

Hi Francesco,

can you do:

export UHD_LOG_LEVEL=1
uhd_usrp_probe

and share the generated /tmp/uhd.log?
Also, how did you get the FPGA image?

Best regards,
Marcus
On 09/30/2016 07:24 AM, Francesco Giannone via USRP-users wrote:
Hi All,

I’m quite new of this field. I started to use USRP because I’m working with a 5G network simulator/emulator.

I have a NI USRP 2940 R in which  I installed the Ettus X310 firmware. When I run the code I get this error: 

UHD Warning:
    Unable to set the thread priority. Performance may be negatively affected.
    Please see the general application notes in the manual for instructions.
    EnvironmentError: OSError: error in pthread_setschedparam
Checking for USRPs : UHD 003.010.000.000-release (3.10.0)
Found USRP X300
-- X300 initialization sequence...
-- Determining maximum frame size... 1472 bytes.
-- Setup basic communication...
-- Loading values from EEPROM...
-- Setup RF frontend clocking...
-- Radio 1x clock:184.32
terminate called after throwing an instance of 'uhd::assertion_error'
  what():  AssertionError: block_def
  in void uhd::usrp::device3_impl::enumerate_rfnoc_blocks(size_t, size_t, size_t, const uhd::sid_t&, uhd::device_addr_t, uhd::endianness_t)
  at /build/uhd-SfT4TV/uhd-3.10.0.0/host/lib/usrp/device3/device3_impl.cpp:148

Aborted (core dumped)

Any ideas?

Thanks a lot in advance!!

Best Regards.

Francesco.
 


_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com


_______________________________________________
USRP-users mailing list
[hidden email]
http://lists.ettus.com/mailman/listinfo/usrp-users_lists.ettus.com